1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

MVP Plus pump is stuck on. Please Help!

Discussion in 'Western Plows Discussion' started by igloo_kid, Dec 20, 2013.

  1. igloo_kid

    igloo_kid Junior Member
    Messages: 14

    I have a 2007 MVP Plus and the hydraulic pump stays on. I was just plowing this morning like normal and noticed my lights were dimmed down so I got out of truck and heard the pump stuck on. Does anybody know the problem? Please help! Thank you.
     
  2. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    This is probably your motor relay stuck on. You can disconnect the big cable at the grill to make it stop. On an MVP plus the relay is located behind the black plastic shroud on the left hand side of the plow. Remove the rubber ring on the bottom of the hydraulic unit, then the rubber retainer on the top by the filler plug. Now slide the left hand cover off. Inside there you will see the motor relay. It's a bit of a bugger to change but not impossible. 7/16 bolts hold the relay on and 3/8 & 1/2 inch nuts hold the four wires. Be sure to unplug the big cable on the plow before touching or you will get sparks as this is connected full time to battery positive.
    When you get the new relay be sure to buy one that is "intermittent" use. The old relays used on the previous generation were continuous but they are designed to be installed closer to the battery under the hood. Part #42902 The other kind will work but are not ideal. They fail to operate when your battery is low or you have a bit of a bad connection at the grill. In any case this is the one that Western wants us to use on the new Fleet Flex units like yours.

    This is an easy fix. Just don't try to do it outside in -30 temperatures as you will need all your fingers to work well to get the two mounting bolts back in. As I said, they are not nice....
     
  3. igloo_kid

    igloo_kid Junior Member
    Messages: 14

    Thanks for the help. I have a friend flying in my part today so I'll let you know how the project goes. I was told that the controller could be the problem too so I plugged in my new spare controller and just got the same results.
     
  4. igloo_kid

    igloo_kid Junior Member
    Messages: 14

    Thanks

    Thanks Mishnick! Got the new relay on and now works perfect! Thanks for the help! Happy Holidays!