1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

MVP Plus Dead in the Snow Pile

Discussion in 'Western Plows Discussion' started by Team_Arctic, Dec 11, 2009.

  1. Team_Arctic

    Team_Arctic Senior Member
    Messages: 176

    I have a mvp plus that is dead. Wont do anything at all.. started out yesterday by making a clicking noice from the relay ... changed the relay this morning .. clicking noise is gone but not i have nothing. i can here the solinoids clicking on and off with the push of different buttons but no movement. motor is good. i jumped across the relay and motor kicks right on... any ideas.. did i get a bad motor relay? could it be something in the plow module?
     
  2. Schwinn68

    Schwinn68 Senior Member
    Messages: 164

    I know this may sound dumb but you should try a different controller. We had a problem with one of our plows the other night and it turned out to be the controller.
     
  3. Team_Arctic

    Team_Arctic Senior Member
    Messages: 176

    and i had thought about that but a controler is 300bucks and thats the only mvp i have that can use it
     
  4. Green Grass

    Green Grass PlowSite Fanatic
    Messages: 9,573

    what isolation module do you have? do you have the 4 prong plug on your controller?
     
  5. Team_Arctic

    Team_Arctic Senior Member
    Messages: 176

    i have a four prong controller and i will have to look at the iso mod to check what one it is for sure the blade is abotu 2 years old or so and have had much of any problems besides and o-ring on the power pack and and o-ring on one of the cylinders.
     
  6. Team_Arctic

    Team_Arctic Senior Member
    Messages: 176

    also i tested at the motor solonoid on both trigger wires and got notning no matter what button on the control i would push... but the plow will still go into float on the controler with the green light comming on
     
  7. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    If you have a "4port" "2 plug", check the controller fuse (7.5 amp) plug in to #1

    Diagram 4 port

    mod4.jpg

    3 port "b/c

    3prog.jpg

    mod4.jpg

    3prog.jpg
     
  8. Team_Arctic

    Team_Arctic Senior Member
    Messages: 176

    fuse is ok, it is the 4 port iso there is power to the controler and it will activate the function solonoids ( i can hear them clicking) and the controler will go into float mode but it will not turn the pump on both small wire to the motor relay/solonoid are dead nomatter what function i try to do with the controller.

    where can i find a wire diagram for the controler so i can do some testing on that?
     
  9. Green Grass

    Green Grass PlowSite Fanatic
    Messages: 9,573

    Western web site has every diagram you could ever need. the controllers on the 4 wire plug controllers operate the plow off resistance in the controller. If you hear the relay click then it is seeing the request from the controller it is something after the relay.
     
  10. Green Grass

    Green Grass PlowSite Fanatic
    Messages: 9,573

    Arctic are your relay on the plow?
     
  11. Team_Arctic

    Team_Arctic Senior Member
    Messages: 176

    best i can understand from what their website is saying to get the plow to do anything it completes a ground for it to do so... how do i know what it is trying to ground on the connector pin for the controller... i can find everything but that right now at the controller i have 3 hot wires and one neg wire
     
  12. Green Grass

    Green Grass PlowSite Fanatic
    Messages: 9,573

    If your relay used to click and all you did was change the relay and now it does not make any noise I would try a different relay and make sure that your connections between the plow and truck are clean and making good connection. I had a problem with that on a western straight blade once where if you wiggled the connector it would work then stop working
     
  13. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Here is the information on the controller and the electrical diagram. Both came out of the PDF file.

    Clipboard01.jpg


    Electrical diagram

    electrical sc.jpg


    Mechanic's guide PDF link

    http://www.westernplows.com/pdf/27366.01_021508forWeb.pdf

    Download it, save it, and print it.....It has the trouble shooting section that can help you out..

    Clipboard01.jpg

    electrical sc.jpg
     
    Last edited: Dec 13, 2009
  14. Team_Arctic

    Team_Arctic Senior Member
    Messages: 176

    call me ******.... i never checked the fuse for the relay hot wire... :( but im up and running.. at least i think i have to put fluid back in it and everything now. because i had the whole thing tore down
     
  15. Green Grass

    Green Grass PlowSite Fanatic
    Messages: 9,573

    atleast it was a cheap fix!!
     
  16. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    At least you solve the problem. Merry Xmas

    Still download the PDF and keep it somewhere for future use..