1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

MVP left side only pulls back won't push forward

Discussion in 'Western Plows Discussion' started by simply_peter, Dec 17, 2012.

  1. simply_peter

    simply_peter Member
    from Iowa
    Messages: 32

    I have an UltraMount MVP (not the plus model) and the left wing is only working consistently in pull back mode. I can't get it to go forward without working it like a straight blade.

    Anyone have any troubleshooting recommendations?

    It works intermittently, but when it's not working it seems like it's not switching from backward to forward when I hit the button the second time. Each time I hit the button it moves back until it hits the stops.

    Thanks,
    Pete
     
  2. simply_peter

    simply_peter Member
    from Iowa
    Messages: 32

    Reading the Western mechanics guide it looks like the S4 SV08-30 Solenoid Cartridge is part of the movement control and is the only function in the list that isn't working. I haven't taken anything apart yet.
     
  3. dibby712

    dibby712 Junior Member
    Messages: 1

    Did you figure it out? I have the exact same plow doing the same thing. Checked and replaced solenoid and no luck. looking for some help. Thanks