1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

motor runs but plow doesnt raise or angle

Discussion in 'Fisher Engineering Discussion' started by Henry0016, Dec 13, 2007.

  1. Henry0016

    Henry0016 Member
    Messages: 51

    This morning put plow on for the first time this season. It was on a pallet so i hooked it up pluged it in. It lifted off the pallet os i backed up droped plow and now the motor runs but wont lift. Any help will be great.

    I filled all fluids and still nothing
  2. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    Well if we knew what plow it ws, might be able to help.

    Going to Assume it is the 8' Fisher??
  3. mcwlandscaping

    mcwlandscaping 2000 Club Member
    Messages: 2,557

    is this a SEHP system or Insta-act system?

    If insta-act, check power to the three solenoids on the plow and also make sure your under hod solenoid is tripping like it should...

    http://fisherplows.com/publications.asp?cat=36 here are the two mechanics manuals....choose the one for your plow and check all your electical components with a test light or multimeter.
  4. Henry0016

    Henry0016 Member
    Messages: 51

    Its a sehp I drained fluid and cleaned filter. put new fluid and it works now
  5. Henry0016

    Henry0016 Member
    Messages: 51

    and it is 7 1/2
  6. Plow Dude

    Plow Dude Senior Member
    Messages: 280

    I am having the same problem today. The plow wont go up or to the left. The motor is getting power, so I don't think its the solenoid. I think there is a bad connection between the wire harness hook ups from the truck to the plow. It is a MM2, just to let you know. Hopefully it can be fixed before we get this foot of snow tonight!
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If it won't raise or angle to the left then the S3 valve isn't opening...

    If you want to verify it, you can check the Lt blue wire on the S2 coil. I think your gonna find it isn't getting power due to a poor connection (as you already suspect).