1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

More 810 problems... only action plow will do is angle left

Discussion in 'Blizzard Plows Discussion' started by RamirezOrchards, Dec 18, 2010.

  1. RamirezOrchards

    RamirezOrchards Member
    from CT
    Messages: 41

    Well after fixing my previous problem, I went ahead and installed some firestone airbags today. I decided to put the plow on to see how it sat with the suspension and every thing was working fine. Then, I checked the wings and angled the plow all the way to the left until it hit the stop and everything just stoped working. The only thing the plow does now is angle left and I cannot even take it off from my truck as the power hitch is down as well (toggleing the power hitch also angles the plow). I found out after some tinkering that I am able to push the plow back to the center position, as if there is no pressure in that line. I am now stuck with no truck and a non working plow. What could be the problem??
     
  2. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    Remove, disassemble, and clean your valves. You may have a screen stuck in your angle valve.
     
  3. RamirezOrchards

    RamirezOrchards Member
    from CT
    Messages: 41

    I managed to take out both left and right angle valves (s3 and s4) and upon visual inspection I did find some debris on s3. S4 looked fine but I was not able to find a screen. Is it located on the valve itself? I tried the plow again after a quick clean and it is still acting in the same mannor. Which other valves should I inspect and is there a proper way to check/clean these valves? Sorry for all the questions but I am somewhat new to hydraulics and have snowfall expected tonight. Thanks in advance for any help
     
  4. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    The valve for the RIGHT cylinder (angles the plow left) is stuck open. Remove valve, disassemble by unscrewing the tip. Watch out for the springs, and little parts once you get it unscrewed. You will need a stud puller, or careful use of smooth jaw pliers. Clean with brake clean, then reassemble. Just a word of advice: If you didn't flush your lines when you cleaned your reservoir, you will likely have continued trouble with problems like this. You need to flush your lines, and clean all your valves. The crud you saw on your filter is likely in your lines and causing your valves to stick as well.
     
  5. RamirezOrchards

    RamirezOrchards Member
    from CT
    Messages: 41

    All fixed thanks to you guys! Took out every valve and flushed the system again. Every action works like a dream, especially with my new airbags up front!