1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Mm2

Discussion in 'Residential Snow Removal' started by BobB68, Jan 22, 2016.

  1. BobB68

    BobB68 Junior Member
    Messages: 1

    I need some help on a Minute Mount 2 xtreme V. The plow quit working totally,no motor action and blown fuses, I replaced the motor and fuses and now as soon as i plug the leads into the truck the motor spins non stop with no control. if I remove the trigger wire on the S3 valve then I can get the plow to go up,just to get it off the ground for transport, then I have to disconnect the plow to vehicle connector to get the motor to stop. I replaced the relay at the same time just to save time in the future.
    Any Ideas would be helpful !! I'm thinking maybe a stuck S3 valve, but not sure why the motor is stuck engaged ?
     
  2. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    sounds like you have a bad ground somewhere, check your power cables
     
  3. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,641

    These plows switch the ground side of the circuit. Download the service manual and double check your wiring. Also remember that the power harness from truck is hot all the time so make sure you unhook it before working on the plow.