1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

mm2 xblade motor stuck on

Discussion in 'Fisher Engineering Discussion' started by nor'easter1, Jan 13, 2011.

  1. nor'easter1

    nor'easter1 Senior Member
    Messages: 140

    I have a 2008 8'6 straight xblade and it is awesome. However during this recent storm I hit raise and bam up the blade went angle right and plow motor would not shut off. well I have been through this before and said blown solenoid. Replaced old one then it happened two more times. It would self fix if I shut power box off then truck gave it ten seconds and re fired it would run great. Seems to happen when my blade is angles right and I go to the straight position it will go all the way left and up when this occurs. Any ideas on what to chase down i would not dare call the local dealer with the 25" we got in one day! Thanks
     
  2. fx4plowin

    fx4plowin Member
    Messages: 47

    I had a similar problem, it actually was the fuse that was blown and just barely making a connection. if that does not work i would start with solenoids, test and then go from there
     
  3. nor'easter1

    nor'easter1 Senior Member
    Messages: 140

    What fuse did you replace ?
     
  4. nor'easter1

    nor'easter1 Senior Member
    Messages: 140

    also thinking maybe my control box thing in cab could be shot, but why would the motor run continuously ? some one in this forum has the answer thanks to all