1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

mm2 wiring problem

Discussion in 'Fisher Engineering Discussion' started by chris694205, Nov 18, 2010.

  1. chris694205

    chris694205 Senior Member
    Messages: 175

    Plow is a mm2 straight blade. When you touch any function on the joystick the motor squeals but the plow doesn't move. But the kicker is that when you let go of the joystick the motor stays on. I have replaced the solenoid now I'm lost
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Defective controller most likely but can also be caused by a poor ground, so go over those first.
     
  3. chris694205

    chris694205 Senior Member
    Messages: 175

    i have tried another controller. im also not sure that one works right either. so ill have to check the grounds i suppose. After i push the controller and the pump is on (even after i let off the controller) i can disconnect one of the wires goin to the solenoids on the plow and it quits.
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Next time it's sticks quickly disconnect the controller and see if it stops, that will generally tell you right away if it's a controller issue. :drinkup:
     
  5. LON

    LON Senior Member
    Messages: 749

    Sounds like the power plug is plugged in backwards. Had a customer who did this once and it did pretty much what your saying - would squeal when button is pushed and then free spool once you left go of button.
    Is truck red stripe power wire across from plow red stripe power wire?
     
  6. chris694205

    chris694205 Senior Member
    Messages: 175

    seems like that could be the case... i checked that today and it turned out that was wired right... i also did what B&B recommended and when i unhooked the controller it shut off. So i guess im going to have to take my controller up and see if that works... hopefully that is the case