1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

mm2 turn signal

Discussion in 'Fisher Engineering Discussion' started by t.i.b, Nov 20, 2013.

  1. t.i.b

    t.i.b Senior Member
    Messages: 140

    I just bought an 04 chevy 3500 with a mm2 straight blade. everything on the plow works except the park/turn lights. The lights on the plow don't come on and the ones on the truck stay on. anyone have any ideas?
    thanks.
     
  2. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    that is a loaded question, so it sounds like the lights don't work at all? sounds like you might have a bad 26357 cable or your lights are not grounded properly.
     
  3. t.i.b

    t.i.b Senior Member
    Messages: 140

    headlights work, high and lowbeams. just no parking or turnsignals. I can hear the iso mod clicking when I use the turn signals. I changed the 2 fuses in the harness.
     
  4. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    did you check the connections? usually you have to tap the turn or park signals to get them to work
     
  5. t.i.b

    t.i.b Senior Member
    Messages: 140

    looking into that now. was hoping someone would have an easy answer before I started digging into it.
     
  6. t.i.b

    t.i.b Senior Member
    Messages: 140

    so the solenoid under the hood that goes from the batt to the plow clicks when the directional are on, that dosnt seem right. im having trouble finding a wiring diagram online. can anyone tell me where to find one?
     
  7. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,652

    Did you have all the connectors hooked up to the plow? Parking lights ground thru the 2 pin connector for the pump power. The parking lights will stay on on the truck with the plow hooked up. Check bumper connector and the bulbs. And the Black w/ Orange wire from lights to pump.
     
  8. t.i.b

    t.i.b Senior Member
    Messages: 140

    thankyou. I just had the other 2 connectors pluged in thinking they controlled the lights (shows what I know). Thanks again, you just saved me a lot of aggravation and time.
     
  9. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,652

    The 2 pin is power for pump motor, and ground for parking lights and valves. 3 pin is power for valves. 11 pin is power for lights. Glad it is working for you now.
     
  10. t.i.b

    t.i.b Senior Member
    Messages: 140

    so the lights worked but now it keeps blowing the 15 amp fuse. any ideas where I should start looking for the problem?
     
  11. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,967

    which 15 amp. There's 2
    And kimber you might be wrong on the 2 pin plug grounding out the lights
     
  12. t.i.b

    t.i.b Senior Member
    Messages: 140

    the 1 under the hood coming outta the port 2 harness. wheres there another 1?
     
  13. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,967

    No that's my bad. I'm thinking of the 3 port Westerns.
    But as far as your fuse, when did it start blowing? What did you change
     
  14. t.i.b

    t.i.b Senior Member
    Messages: 140

    just bought the truck w/ the plow already on it. the fuse was blown when I bought it. the solenoid under the hood looks new. the 1 that goes from the + of the batt to the plow.
     
  15. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,967

    Solenoid has nothing to do with the fuse. Have you looked at the wiring diag on fishers website
     
  16. t.i.b

    t.i.b Senior Member
    Messages: 140

    yes, im not the smartest guy around and nothing jumped out at me. that solenoid clicks if I use the directional and if I unplug the black orange stripe wire to it the headlights go out. does the sound like something is severly miss wired?
     
  17. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,967

    Yea sounds like something is messed up big time

    How many wires are on the solenoid? Should be 2 big and 2 or 3 small
     
  18. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,652

    Turn and park ground thru pump motor. Headlights have their own ground, the separate black w/ orange going to battery.

    The 15 amp fuse is for park and turn. Something is wired wrong or you have a short.

    7.5 amp is for control harness.
     
  19. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,652

    You can get the wiring diagram off Fisher's site, Fisherplows.com.
     
  20. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,967

    Hey kimber....p.m.