1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

MM2 Intermittent Problems Please help

Discussion in 'Fisher Engineering Discussion' started by vffdoug, Jan 11, 2009.

  1. vffdoug

    vffdoug Junior Member
    Messages: 25

    I have a MM2 mounted on a 2000 dodge ram and I am having the following problems.
    I have bright headlights on the passenger side on high and low beam all the time. On the drivers side the high and low beam on plow lights are very dim, barely lit, but sometimes I will be driving and they will be as bright as they should be. I noticed last night the module box seems pretty warm in the area of the 3 and 4 port on the module.
    I even tried jumping a ground from the battery to the driver side plow light and it doesn't make a difference. I have no problems with my truck headlights at all when the plow is removed, just the problem with the plow headlights.
    I have already replaced the headlight harnesses. Also sometimes it makes a slamming noise when raising and lower the plow or angling the plow.
    I just changed the fluid with low temp fluid and made sure I had the air out of the system.
    This was also happening prior to changing the fluid.
    I am just wondering if all of my problems are coming from the module?
    Thanks
    Doug