1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

MM2 headlights stopped working

Discussion in 'Truck & Equipment Repair' started by Sbrewer, Feb 13, 2015.

Tags:
  1. Sbrewer

    Sbrewer Junior Member
    Messages: 6

    hello, I have a 02 chevy 2500 6.0 gas engine that I bought and it had a MM2 8' 3plug set up on it before. I finally bought the same type of plow the other day and plugged everything in and it all worked great. Now when I plug it in my headlights go off on my truck but don't turn the plow head lights on (only the orange side lights come on ) I cleaned the connections and added some of that electric grease stuff , wiggled connection etc and they don't come on at all.i checked the bulb on one side and its fine. it worked fine the first day so im stuck and a blizzard is coming. the only thing I notice is the high beam light on the dash is always on when the plow is plugged in no matter what light setting I change it to. (not sure if that's normal) so basically everything works except plow head lights. I read there are fuses in the isolatation module etc but don't even know where that is. this truck has all kinds of buttons for front light strobes etc and had a sander on it before ,also has 2 batteries. (sorry im just trying to include every detail I can think of to try and make it easier) where should I start please? I also have a brake light out but don't think that would effect anything. Plow side have fuses somewhere? thanks guys and sorry for my stupidity !

    new plow.jpg
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,974

    So it had a mm2 on it before and your positive the lights worked on that one?
     
  3. Sbrewer

    Sbrewer Junior Member
    Messages: 6

    yes I bought it the other day and plugged it in and every thing worked great. the side marker lights turn on and truck markers stay on,headlights turn off when I plug that one plug in "short plug " I didn't mess with anything so do you think it might be a fuse ? I checked the plugs as far as being loose etc and cleaned them but the lights don't blink on or anything. thanks so much for responding. we have another blizzard coming later today and im stressing bad.
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,974

    Could be a fuse. There's 4 on your system. Start there first.
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,974

  6. Sbrewer

    Sbrewer Junior Member
    Messages: 6

    thank you so much! I drove a few hours to buy it off a funeral home because they upgraded to a Vplow to help move some snow better in their lots. paid $1200, it has no rust or anything. worked great all the way home and til next day. I almost missed out on it, a lot are posted on craigslist for 2grand or so. thanks again
     
  7. Sbrewer

    Sbrewer Junior Member
    Messages: 6

    i cant even down load that link to see, sorry. I see my module and am trying to look for fuses near it. the one thing I def noticied is the plug truck side had a zip tie on it and the plow side pulled on it and the black sleeve us pulled back a tiny bit exposing all the dif color wires. I cut the zip tie and tried wiggling connection etc but still no flickering or anything. (only orange side lights go on whn I plug it in and my headlights go off like they should) any one that wants to plow head to mass :) the national guard is even out!
     
  8. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,974

    Try this.....

    Screenshot_2014-12-16-03-44-50.jpg

    Screenshot_2014-12-16-03-23-44.jpg
     
  9. Sbrewer

    Sbrewer Junior Member
    Messages: 6

    now when I shift in gear 1 plow light on passenger side goes on. if I put it in park it goes out :cry:
     
  10. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,974

    Well don't put it in park. Just keep going

    That almost sounds like you hooked into your drl lights instead of the actual head lights.
     
    Last edited: Feb 14, 2015
  11. Sbrewer

    Sbrewer Junior Member
    Messages: 6

    man i cant thank you enough ,all set now! I really appreciate you taking the time to help me. I wish you could make it to Salem, Ma 20 miles north of Boston in a area called the North Shore. I think we have been getting more snow than anyone. We had a blizzard a few weeks ago and another coming tonight. I will probably be out til Tuesday plowing. NO ONE can keep up with the work demand, NY,NJ,Vermont have sent a lot of equipment including huge snow melting machines, the National Guard has also been out/ So much work but not enough people! We didn't really get any snow til late Jan. Im just a single dad trying to make a little bit of money. I have no clue on what to charge for driveways " everyones calling" I just like helping people and am a sucker when it comes to giving prices. I hope you are doing well this winter and if you start heading to Mass now you can make some big money! You always got a place to stay if you ever come here. Thanks again!
     
  12. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,974

    So what was it?