1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

mm2 hd problems

Discussion in 'Fisher Engineering Discussion' started by JRS Landscaping, Jan 18, 2015.

  1. JRS Landscaping

    JRS Landscaping Senior Member
    Messages: 103

    hit any function on controller except down/float the plow jerks just a bit like its trying to angle to the pass side. motor turns on and sounds like pressure building but isn't going anywhere. I know for a fact its plow side related truck runs other plows fine. I checked all the coils and they are magnetizing when they should be and have the correct colored wires going to them. I feel like its a stuck valve. I pulled one valve out before it got dark and it looked decent and not rusty. Any way to test them?? Fluid looks decent but I'm going to drain. I have no history on the plow, however i do know it sat for a year or 2. i just got it. Any help would be appreciated. :mechanic:
    Last edited: Jan 18, 2015
  2. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,593

    Check and clean all your electrical connections, sounds like a possible bad plug end.
  3. JRS Landscaping

    JRS Landscaping Senior Member
    Messages: 103

    doubt its wiring related. but i think i have a new motor control harness ill plug it in see what happens
  4. NHresident

    NHresident Senior Member
    Messages: 285

    have u chkd the fluid level ? IF the motor is operating and u have nothing u either have low fluid ur in tank screen is plugged the pickup tube fell off the pump went bad (unlikely) or u got a bad s3 cartridge after fluid chk id clean out the s3 cartridge then if needed id do a pressure test on the lift cylinder port u should get at least 1750 psi since the plows sat the 2 manifold bolts that hold the insta act to the structure could be seized so u want to go easy on unbolting them to get the unit off so u can get the can off to chk the filter and tube that's why id chk those last
  5. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,214

    Like stated above check your fluid level first and make sure it is full and the condition is good.Since you just got I would change the fluid,pickup tube,and suction filter.Spray some PB blaster on the bolts that mount the pump to the headgear.The pump is aluminum and the bracket is steel so the bolts are probably full of corrosion and will snap if your not careful.Then you have to drill them out. (Not fun)
  6. JRS Landscaping

    JRS Landscaping Senior Member
    Messages: 103

    all good now! bad s2 and s3 cartridge!
  7. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,214

    Just in time for snow!