1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

MM1 problems

Discussion in 'Fisher Engineering Discussion' started by Snowplow71, Aug 28, 2008.

  1. Snowplow71

    Snowplow71 Senior Member
    Messages: 283

    I hooked up the 8 foot MM1 today to move it. The plugs that plug in the lights, seem ok. But the wiring going to the plugs (on the plow side) are coming out of the covering or what ever you want to call it. Then, the plow wouldn't raise, and the truck lights came back on. I had to wrap it around the jack lever, and run to the truck to lift it. Also the end of the wires, on the plow side, when going to the motor and solonids??? are exposed to the weather. Does anyone know how much a brand new harrness for the plow side only is? Going way to big to have break downs, and trying to prevent them. Thanks, and also the right (passenger side light is out, but I am going to put Nighthawks on anyways. Thanks guys!!
  2. NorwayAuto&Plow

    NorwayAuto&Plow Senior Member
    Messages: 160

    Have someone wiggle the wires around and bend them to all directions while you try to raise and angle. If it starts to work then you need a new harness or just get one of the clips that hold the connection at an angle.

    I read the post quick so i hope this helps.
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You definitely need the plow side harness replaced/repaired. If your going with the Intensifiers, that'll take care of that side of the plow harness. Then you simply need the motor side battery cables to complete the repair. Fisher p/n: 21294. Should be around $40 or so.

    Make sure the truck side is good as well or you'll continue to have troubles.
    Last edited: Aug 29, 2008