1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

MM1. No down, parking or headlights. Worked in October

Discussion in 'Fisher Engineering Discussion' started by Carpenter98, Jan 20, 2012.

  1. Carpenter98

    Carpenter98 Member
    Messages: 41

    Hi guys

    This has not been a snowy winter for us. Last snow we had was Halloween. I had my plow on then and it functioned fine. They are calling for 3-5" tonight so I hooked the plow up tonight and headlights and parking lights wont work. The plow goes up, left and right but won't go down. Checked the ground connections and they are fine.

    Are the 2 little black squares relays? I unhooked a couple of plugs and could hear it 'click' when I hooked them back up. Only some of the wires made the 'relays' click. Could this be a possible problem?

    All the rest of the connections look fine. What confuses me is that it worked fine in October but now I have these issues. Any ideas?

    Thanks in advance.

    Jeremy
     
  2. Lone136

    Lone136 Senior Member
    Messages: 108

    The relays control the head lights. Make sure you have good ground there and so make sure you have power. All the relays do is turn your truck side head lights and turn your plow lights on. You may have a bad relay
     
  3. Carpenter98

    Carpenter98 Member
    Messages: 41

    Thanks. How hard are the relays to find? Would NAPA have them? I have nearly every other replacement part except those.

    Any idea why the red light is not on on my joystick and it won't go down?
     
  4. Lone136

    Lone136 Senior Member
    Messages: 108

    I would check the plug between the plow and truck. The pins can get bent or just pluged in all the way. Also check the fuse for the controllor. In a 3 port or 4 port the plow has to be pluged up to the plow for the controller to work at all
     
  5. Carpenter98

    Carpenter98 Member
    Messages: 41

    It is a 2 plug system. I'll check the pins in the morning. It seems to me if the controller light is not lit, it shouldn't be able to lift or turn the plow, but it does.
     
  6. Carpenter98

    Carpenter98 Member
    Messages: 41

    Ok. plug is clean. controller light still won't light up but the plow goes up, left & right. The light comes on dimly when I move the stick up, down and left. The controller fuse is fine. Ideas?
     
  7. buddymanzpop

    buddymanzpop Senior Member
    Messages: 599

    Check all the wiring for bad or connections or a broken wire, check the fuses in the harness for the headlights, also have someone wiggle the connection at the grill plug to see if any thing changes, look closely at the wire in side of the grill plug for broken wires (very common wire break place).
     
  8. Carpenter98

    Carpenter98 Member
    Messages: 41

    I got up at 430 this morning and screwed around with the wiring, out in the snow...

    Found a loose wire in the plow-side plug, so in desperation I just cut both plugs off and crimped all the wires together. That solved the plow down issue.

    I still didn't have lights so I cut the armaflex off. Turns out the previous owner spliced in new wires and 2 of them had come out of the connectors. So I cut out all the old connectors and crimped in new ones. Lots of dielectric grease and electrical tape later and I was ready to roll out at 6am. Glad it is Saturday and most of the places I do are closed or open later than weekdays.

    Anyone know a good source for both the plow and truck side plugs?

    Thanks for the help