1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

mm1 insta act slow or no movment

Discussion in 'Fisher Engineering Discussion' started by hym123, Jan 21, 2012.

  1. hym123

    hym123 Junior Member
    Messages: 2

    I hooked up my plow for first time this year when going up acted very funny went slow when went to the left it did the shake movement but went left to right was the same slow but no shake thought maybee low on fluid was a bit low added but still the same,i cracked hoses at pistons moved left fluid came out i tightend added more fluid to resivore then did the same on right piston and up piston still slow and shake to left. went plowing got a little better than went bad and barly can get to go upor left or right if i tap controler can get it to come up a little at a time, selonoid makes noise but no movement is it a screen problem or valve or did i bleed out wrong and made it worse by adding fluid and opening hoses next to pistons and not up by pump ? any help would be great thanks eric
     
    Last edited: Jan 21, 2012
  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,652

    Check the filter in the reservoir.
     
  3. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,238

  4. hym123

    hym123 Junior Member
    Messages: 2

    thanks i will do that today and see if that is the problem since all directions dont work do you think all the valves could be cloged or not likly
     
  5. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,652

    I would start with the filter in the reservoir, if this is really dirty then you may want to check the valves just to be sure. May also be a good idea if everything is dirty to flush the system with meyer hydra flush.