1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

minute mount problem

Discussion in 'Truck & Equipment Repair' started by rel583, Jan 20, 2012.

  1. rel583

    rel583 Junior Member
    from 02338
    Messages: 3

    :mechanic:plow will not go up ,will not turn left or right motor spins but doesn't seem to engage any ideas thanks
     
  2. dooleycorp

    dooleycorp Senior Member
    Messages: 121

    check all electric connections and get some crc electrical cleaner start there
     
  3. If the pump operates with the controls check fluid if not that take the unit apart and clean the inside exp the pickup tube and filter
     
  4. woodchuck2

    woodchuck2 Senior Member
    Messages: 304

    Check the ground for the solenoids, doubt you would lose power to all the solenoids at once but the one ground could be lost.
     
  5. Snow Commandor

    Snow Commandor Senior Member
    from 07666
    Messages: 439

    Good advice, Woodchuck. Check the common ground for the solenoids. Chances are that ground is bad.
     
  6. 02powerstroke

    02powerstroke PlowSite.com Addict
    Messages: 1,188

    this happend to me last year my filter was clogged in the fluid res
     
  7. Snow Commandor

    Snow Commandor Senior Member
    from 07666
    Messages: 439

    Another good thing to check, Powerstroke.