1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Minute Mount One Problem

Discussion in 'Fisher Engineering Discussion' started by brfootball45, Nov 18, 2010.

  1. brfootball45

    brfootball45 Senior Member
    Messages: 172

    Hey whats going on? I recently just bought a 9' Minute mount one 2 plug for my truck. The guy i bought it off said it recently just had a new pump put on it. My problem is when i go to angle it in either direction it will angle then stop. If i wiggle the plug that connects into the truck side it will eventually angle fully. It goes up and down fine im just having trouble with angling. There are no leaks or noises. Someone suggested to get new plugs on the plow side. And one other the ground wire from the solenoid that ground on the pump it self looks like it needs to be replaced could this be the issue?
     
  2. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,033

    Replace the 9 pin ends.
     
  3. justme-

    justme- 2000 Club Member
    Messages: 2,138

    The 9 pin connector plowside is notorious for having wire breaks near the connector- replace it and all should be well. When I did mine I cut back only 2 inches or so to get behind the broken wires and added the replacement there which left me with a longer 9 pin side harness. The extra length gives more slack and from what I see less movement to the wires at the break point so it should not reoccur (atleast it has not so far after several years)