1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Minute Mount 2 Light Problem

Discussion in 'Fisher Engineering Discussion' started by unhcp, Oct 31, 2011.

  1. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,244

    Hooked up my 9 foot mm2 plow and only 1 light is working, I switched out the lights with another pair and still the same thing.

    So I am 99.9% sure it is truck side. Is it just the cable or could it be something else?
     
  2. buddymanzpop

    buddymanzpop Senior Member
    Messages: 601

    Go to your configuration plug.
     
  3. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,035

    I would check the connector to the headlamp for juice first...check on both side of the connector, it may just be the connector. Trace the harness from there back if that checks out...could be the connector at the grill, gunked pin, or chaffed wire.

    Is this a new install, or existing?
     
  4. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,244

    existing install, new truck to me, same plow though.

    I will buy the plug and see if that solves the issue.
     
  5. buddymanzpop

    buddymanzpop Senior Member
    Messages: 601

    What plug are you going to buy? What year make and model truck did plow come from? What type headlights HB1/HB5 or 2B on your present truck, what headlights on donor truck?
     
    Last edited: Nov 1, 2011
  6. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,244

    I was going to buy the truck side light plug that comes off the isolation module and hooks into the plow lights.


    The existing truck is a 07 Ford Superduty, it had a 8 footer and I just got a 9.
     
  7. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,035

    Does the high beams, and or park lights work appropriately?
     
  8. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,244

    The parking lights work I know that for sure, not sure about high beams.


    So I have 1 plow light on the driver side that is fully operational and the passenger side plow light has the parking light, but the headlight is lit up on the truck and not the plow.
     
  9. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,035

    Double check your connections first and foremost, starting at the trucks headlight and working your way out to the ISO.

    Is this a 3 or 4 port?
     
  10. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,244

    3, I checked the connections they looked ok, but I am no mechanic.

    any ideas?
     
  11. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,035

    unplug and re plug them. I'm almost 100% sure that your truck doesn't require a configuration plug. I'm still trying to get my plowing hat on for the season, so I could be wrong about that.
     
  12. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,244

    I visited Alton Motorsports and was going to buy the 11 pin connector, but they advised me to check the headlight connections first. So I checked the passenger side headlight and switched the 2 plugs vice versa and now it works! Someone must've replaced the headlight and plugged in the wrong plug!
     
  13. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,035

    That's what I thought.