1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Meyers help!

Discussion in 'Commercial Snow Removal' started by Jeffro, Nov 8, 2003.

  1. Jeffro

    Jeffro Member
    Messages: 33

    new to the site, been reading for a few weeks now, pretty damn cool you guys take as much pride in this stuff as i do on my Camaro!

    problem i have is it will angle to the left, but not to the right. i have 12 volts on my green wire at the pump, and i removed the solenoid and valve, put the green wire on hot, the solenoid to ground, i hear clicking as though it is working.
    is this a good enough test or should i replace solenoid and valve?
    i'm out of answers, i've done all the trouble shooting i read off of this site and your links....HELP!!!

    TIA, Jeff
  2. Greensway

    Greensway Member
    Messages: 97


    CARDOCTOR PlowSite.com Addict
    Messages: 1,304

    does the 'C' coil - green wire have magnetism

    have somebody hold the swith over put a screw driver on the
    head of the valve is it magnetized

    if it does the c valve is bad

    or stuck try cleaning it with kerosene

  4. Jeffro

    Jeffro Member
    Messages: 33

    c coil has power to it, and does have magnetism.

    i removed them both, stuck the coil on the valave, then put the green wire on battery power, and grounded out the top of the coil.....i can hear the valve"clicking", opening and closing.

    i just hate to buy parts i dont need....

    CARDOCTOR PlowSite.com Addict
    Messages: 1,304

    mill supply has a trouble shooting guide

    it states if the c-coil has magnetism
    are the c-valve o-rings ok
    if this doesnt work replace c-valve
    if problem continues replace the quick connects?

    does the motor run when angleing right
    last resort
    how about if you disconnect the hose
    remove quick connect right angle it and see if you get flow

  6. Jeffro

    Jeffro Member
    Messages: 33

    yes, motor runs when angling right,,,funny though, when flicking swich to right, it angles left, left swich angles left....i dunno.

    fine, i'll get the valve tomorow, and the coil too i guess for the hell of it.

    i was thinking of doing the hose thing too...i'll try that tomorow too.

    let you know what happens...thanks
  7. #1 plowtech

    #1 plowtech Senior Member
    Messages: 253

    meyer no right

    1ST, if you were to energize the motor right from your battery your plow will ALWAYS go to the left. Thats meyers natural function.
    When you hit the switch to the left thats all your doing giving the motor power,no valves moving,no coils being energized.
    When you heard the valve clicking,it does not mean its truly working. I would take the valve out and take a small screw driver or punch and try to push the inner plunger, it should move roughly a 1/16 of an inch.
    I just had the identical problem on friday,and it was the cure.
    Good luck PT.
  8. flatbed

    flatbed Member
    Messages: 36

    this is probably is not the best idea but it worked for me........older ST-84 blade.....E 47 pump....mine sat for awhile...... i found a big tree gave it a nudge working the angle at the same time....once it (unstuck) it worked fine........when all else fails......but don't use your neighborers tree...........
  9. Jeffro

    Jeffro Member
    Messages: 33

    unreal,,,now it only angles to the right!

    went to napa, bought a c coil, didnt have the valve,i'm getting it tuesday. i bought new quick connects, one was feeling hard to get off and on. put the coil on, same angle to the left only. put the new quick connects on....now it only angles to the right?

    WTF!!! now what?!

    i did do the tree thing, moving it several times back and forth while jogging the swich back...nothing.

    the angle cylinders are a little pitted, not as bad as some of them i've seen on peoples plow and they have no problems.

    this truck has been sitting in a friends driveway for about four years....does that say anything to anyone?

  10. festerw

    festerw Senior Member
    Messages: 986

    Did you flush the old fluid?

    CARDOCTOR PlowSite.com Addict
    Messages: 1,304

    something doesnt seem right

    cardoctor:nono: :nono:
  12. Jeffro

    Jeffro Member
    Messages: 33

    i give up till tuesday, i guess i'll put the valve in and see what happens.

    no, i didnt flush the fluid, how do i bleed it if it only angles one way and not the other? fluid looks fresh though, i did buy some and topped it off.

    thanks alot for all the help so far...up date on tuesday!

  13. flatbed

    flatbed Member
    Messages: 36

    the Meyer book said it could be leaking or open crossover relief valve...........clean or replace ..........look in FAQs for bleeding.......
  14. roblandscape

    roblandscape Senior Member
    from Phila
    Messages: 187

    My problem is I have an E-47 pump hooked up to my E-60 touchpad and wiring harness, I press the touchpad to angle left and it goes right, I touch it to go right and it goes right? HELP:realmad:
  15. tileman

    tileman Member
    Messages: 55

    left and right angle

    here is a trouble shooting guide.

  16. tileman

    tileman Member
    Messages: 55

    try this Tileman

  17. theholycow

    theholycow PlowSite.com Addict
    Messages: 1,180

    Tileman: The resolution of that image is too low; even after enlarging it, the text is unreadable. It looks like quite a useful chart.
  18. tileman

    tileman Member
    Messages: 55

    Troubleshooting Guide

    :( Sorry I was hoping it would come out better.

    If any of you would like a copy, pm me with and email address and I will send it to you.

  19. Jeffro

    Jeffro Member
    Messages: 33

    c valve worked beauty-ful. thanks guy's....

    i think the reason why it started only turning the other way is because i poked the piston in the valve to move it around, maybe i moved it in a different position?

    when is the snow coming???!!!!
  20. KenP

    KenP Senior Member
    Messages: 197

    'll be a smart a$$ on this one, Can I hear a group WESTERN fellas!!!!! SAy it with me W E S T E R N !!!!! Good job men and ladies