1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Meyers E60

Discussion in 'Truck & Equipment Repair' started by accare1004, Dec 8, 2009.

  1. accare1004

    accare1004 Junior Member
    from 68803
    Messages: 3

    I have an older meyers E60 having problems motor running slow up and angle Motor is drawing over 200 amps Ran jumper cables to motor same problem Motor was taken off and checked at a starter repair shop Checked Good.Is there any thing in side pump that would cause hi amp draw on motor??? Thanks for any HELP.
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    if you filters are plugged that would do it. a bad ground is a sure bet also. check all electrical connections and make sure they are excellent.
     
  3. accare1004

    accare1004 Junior Member
    from 68803
    Messages: 3

    I have not checked filters.All electrical is great.Where can i get a parts brake down to see where filters are?? Thanks for the reply
     
  4. accare1004

    accare1004 Junior Member
    from 68803
    Messages: 3

    Well I need to find a new electric motor shop because the motor burnt up this morning. New motor works GREAT
     
  5. ED922

    ED922 Junior Member
    Messages: 20

    hey if you are looking for info on any meyer parts go to the offical meyer web site and look under tech support