1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Meyers E60 wont raise blade

Discussion in 'Meyer / Diamond Products Discussion' started by jslawncare, Feb 13, 2009.

  1. jslawncare

    jslawncare Member
    Messages: 57

    so i just replaced my sump base(meyers) and motor (aftermarket). now although i havent set the pressure i cant get blade to come up. left and right works fine. pump raises without blade. lowers fine without blade with me pushing down on it and someone else hiting slick stick down.

    i know im supposed to set pressure but shouldnt i be able to get it raised by playing with pressure screw? ive had it everywhere.

    im getting a gauge later today to check.

    i never messed with the PA Block or valve. because they all where working.

    any ideas.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Pressure is low for one reason or another. Incorrect relief setting, incorrect relief valve assembly, leaking pump-to-plate O-ring or check valve O-ring.

    It angles with the low pressure since it takes little pressure to do so in comparison to lifting.
     
  3. jslawncare

    jslawncare Member
    Messages: 57

    so should i basically take it apart and do it again?

    and another question in the service manual section 3-74 theres a diagram showing the assembly order of the pump check valve. my question is should that round piece that holds the o-ring be facing up (o-ring side up) or down (o-ring side down) mines up. like diagram shows, but im not sure if thats what they mean by the picture.
     
    Last edited: Feb 13, 2009
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    I wouldn't do anything until you get a press gage on it first.
     
  5. jslawncare

    jslawncare Member
    Messages: 57

    k speaking of the pressure gauge. any idea where i can get 1. my mechanic buddy didnt have 1 that went that high.

    wonder if sears or home depot has 1
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Not likely but a local hydraulic shop, industrial supply shop, or a local Grainger will.
     
  7. jslawncare

    jslawncare Member
    Messages: 57

    haha i was prob on my way to grainger when u posted that. $28

    ill go hook it up now. wheres the best spot.
     
  8. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Tee it into the right hand angle hose and then angle the plow full left until it hits the relief and read the pressure.
     
  9. jslawncare

    jslawncare Member
    Messages: 57

    k i also just read that the pump should spin smooth and easily with just 2 fingers mine didnt. i remeber it being tight. but ill go test now
     
  10. jslawncare

    jslawncare Member
    Messages: 57

    pressure at 2500....im going to weld something on my buddies mustang and have a few beers (he has to get me drunk to work on the ford! LOL chevyman

    be checkin 4 updates tonight and do more work tomorrow
     
  11. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If you've got 2500 on the gage then you have a lift cylinder problem...namely the inability to build pressure in it. So likely its a leaking cylinder base O-ring in the sump base (since you just had it apart). Time to tear it down.
     
  12. jslawncare

    jslawncare Member
    Messages: 57

    dam i put a new 1 in cant see how that would have got screwed up. i guess ill just rip it apart and try again
     
  13. jslawncare

    jslawncare Member
    Messages: 57

    ok so i replaced the o ring and the packing cup. now it only goes up about 3-5 inches then stops. a few times it actually did go up all the way,but that was rare and with excessive up and down crap.

    im stumped
     
  14. kashman

    kashman PlowSite.com Addict
    Messages: 1,070

    how fast dos it come down
     
  15. jslawncare

    jslawncare Member
    Messages: 57

    comes down fine. i even jacked it up then made the pump go up it holds fine and goes down fine
     
  16. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Better double check your pump pressure. Sure sounds like its low or the motor is weak. Those are the only two reasons it will angle but not lift AND hold the plow up once you get it there.
     
  17. jslawncare

    jslawncare Member
    Messages: 57

    got pressure at 2500. what i did was take a extra hose. 1 end has the quick connect the other has the gauge. i didnt have the harware to actually tee it in. id imagine its still a acurate reading. correct?

    it lifts to the same spot everytime. (excepth the 2 times it actually went up somehow)

    the motor is new aftermarket from angelos
     
  18. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    What happens when it stops raising? Does it just continue to run but doesn't raise, or does the motor stop dead also?
     
  19. jslawncare

    jslawncare Member
    Messages: 57

    it acts/sounds as if its fully up. motor turns you can even hear the difference in sound just like when its up.
     
  20. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Important detail there. You've either got mechanical interference or a defective motor or electrical supply to the motor.