1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Meyers E47 NO POWER.. help!

Discussion in 'Commercial Snow Removal' started by jonw440, Dec 26, 2002.

  1. jonw440

    jonw440 Senior Member
    Messages: 139

    I have an old E47 I think... decal is rubbed off. Anyways.. I have no power. I hear the solinoid on the side fender clicking. I swaped it for a working one and still just clicking. This also happends with the truck running. I have 13.50 volts at the plow battery. I checked the black wire disconnect near the motor. I have 0 volts. I spliced in a new wire from the switch to the pump motor (black wire) still no power.
    How do I check the switch. Oh it aslo just clickes when I hit the right/left switch also. Could my pump motor be bad?
    Please help... The truck is stuck in the middle of my driveway.
    Nice site.. I added it to my favorites.
  2. tovoninc

    tovoninc Senior Member
    Messages: 105

    This diagram helps me all the time. This should be a good start. If all else fails use a floor jack to raise the plow and adjust the lift chain to keep it off the road while you drive to a mechanic.


    good luck & by the way, you can use the search feature to visit this discussion many times over. I have a Meyer E-47 so I can appreciate your dilemma.
  3. firemedic680

    firemedic680 Member
    from BG Ohio
    Messages: 49

    You need to make sure that the motor is gettin 12v on the large wires. If it is , you more than likely have a bad motor. I have had a motor do this to me once and i "tapped" it with small hammer and it worked. The motor will get bad spots on the rotor and will not make good contact. When you tap it , it moves to a spot that does make good contact . As long as the motor does not stop on this spot again , you will be ok . Its a crap shoot , but a sign your motor is heading south. Please note i said "tap" and " small hammer" NOT beat the living $&% out of it with a 20lb sledge.
  4. hedgehogg

    hedgehogg Junior Member
    Messages: 15

    if you find that it is the motor you could probally get it rebuilt, or add some new brushes! But if I was you I would pull the ground wire going to the motor and the hot wire and clean the contacts well, or you could just bypass the relay and try to go directlty to the motor with a jumper cable, but I am not sure if this is recommended, I earlier had some up and down problems with my e47 and found that it was the switches, your best bet would be to get yourself a good tester and go from there!
  5. cat320

    cat320 2000 Club Member
    Messages: 2,222

    My plow is acting strange too .Went out this moring to go sand and tryed to raise the plow and nothing happened.But the day before when i went to raise it the plow lights were going on and off I think it might be the joystick but have to check it out.Has this happened to any one else.