1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Meyers E-47

Discussion in 'Commercial Snow Removal' started by FANZDSLPWR, Nov 11, 2003.

  1. FANZDSLPWR

    FANZDSLPWR Junior Member
    from 08312
    Messages: 2

    I JUST REPLACED MY PUMP SHAFT SEAL ON MY MEYERS E-47 BECAUSE IT WAS LEAKING FLUID AND IT WOULD NOT RAISE OR ANGLE. NOW THAT I REPLACED IT THE PLOW LIFTS AND ANGLES BUT IT FEELS ALITTLE SLUGGISH WHEN RAISING. I REMEMBER BEFORE IT WAS MUCH MORE RESPONSIVE. DOES ANYONE KNOW WHAT I SHOULD DO?
     
  2. tovoninc

    tovoninc Senior Member
    Messages: 105

    Welcome to plowsite.

    try bleeding the air from your system.
     
  3. Mac

    Mac Member
    Messages: 77

    When you were in there did you check your filters? Some of the old seal might be suck in the filters. Just my guess. Uses some kerosene to clean everything.
     
  4. A.L. Inc.

    A.L. Inc. Member
    Messages: 97

    I'm having a similar problem with the old E-47 I bought on an 84 Bronco. Tovoninc, is there any way to describe the bleeding process? I hope this isn't a stupid question:eek: Thank you, Mike
     
  5. tovoninc

    tovoninc Senior Member
    Messages: 105

  6. A.L. Inc.

    A.L. Inc. Member
    Messages: 97

    Thank You, Tony. I appreciate it.