1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Meyer problem

Discussion in 'Meyer / Diamond Products Discussion' started by dlcs, Dec 1, 2008.

  1. dlcs

    dlcs 2000 Club Member
    Messages: 2,142

    My e-58h was running fine yesterday afternoon. Went out at 2:30 this morning and the motor would not run. I can here the coils clicking but the selenoid isn't. So, i tried replaceing the selenoid and that didn't help. My controler gives a red fault light when you try to raise or angle the plow. Code on the back of controler says check the white motor wire? The only wight wire I know is the one connected to the selenoid. I cleaned all the grounds and checked the connections, they seam fine. I'm pulling my hair out, this damn plow is going to give me a heart attack. Any suggestions?
  2. Twolf

    Twolf Junior Member
    from Maine
    Messages: 15

    I don't have a Meyer but just recently had the same problem with my Fisher. Turned out that the wire from the battery to the hot side of the motor had enough broken strands in it that not enough voltage was getting to the motor. I had put a meter on it but haddn't looked closely enough at how much was getting there, just that it was, and it was, just not enough. Jumping with a set of jumper cables it would work. I cut and put on new ends and it now works fine. Check all connection, it could be any one of them.

    Good luck