1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Meyer E47 Still Not Lifting

Discussion in 'Truck & Equipment Repair' started by Larry45, Jan 21, 2009.

  1. Larry45

    Larry45 Junior Member
    from Canada
    Messages: 17

    I have a Meyer E47 snowplow and when I'm out doing some plowing, now and then the plow sometimes wont raise, if you keep trying eventually it will work and go up. The worst is on really cold days (-20 for example) then it wont raise at all. You can hear the plow motor go when you push the switch to raise it, but it doesn't go up. What may be the problem? Is it the pump? Will the fluid in it cause this if it is old or maybe dirty (little bit of moisture/water in it). I bought the plow used so I am not really sure when the fluid was changed. It use to work fine (but I always thought it was a little slow raising). The plow is probably about 15 years old. Thanks in advance for any help I can get on this issue.

    *** I did flush and refill with new fluid as requested ***

    I drained the old fluid out, then flushed the main lift ram cylinder with keorsene and cleaned up the 2 filters by the drain plug (the filters did seem to have little ice crystles in them). After I done that and filled it with fluid again it seemed to work fine for a couple of days. Then as before it wouldn't lift on times, and now it wont lift at all. When it was lifting for them couple of days after I drained and flushed it, the temp was warmer and in the +'s and now it is cold again and back down to the -10 to -15 area. What may be the cause of this? Is it possible I didn't flush good enough to get all the moisture and water out and it's still freezing? I drained the fluid and then flushed it with a quart of keorsene. I put the keorsene in the fill hole and just let it poor threw the main ram cylinder, then I pushed the main ram cylinder up and down a couple of time to try and clean it out. Is this what you do? or is there maybe something else causing it not to lift.
     
  2. plowmaster07

    plowmaster07 Senior Member
    Messages: 438

    Did you put in the Meyers snow plow fluid? Also, did you Drain the hoses when you changed the fluid. Also, you could have a stuck valve, or a bad ground to the valve. That would be the next thing to check. If you need a wiring diagram go to www.meyerproducts.com or www.centralparts.com . I found this to be very helpful.
    Good Luck
    Aaron