1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Meyer E47 squealing???

Discussion in 'Commercial Snow Removal' started by SlimJim Z71, Dec 7, 2002.

  1. SlimJim Z71

    SlimJim Z71 PlowSite.com Addict
    Messages: 1,031

    Hey guys! I've got a question for you. A guy I work with just bought a used Meyer 6.5' poly plow, and he asked me why it squeals once in a while. My first guess was that it was cold, but he said it started doing it after it had been in use for a bit. So now I'm thinking maybe it's low on fluid... any thoughts? I haven't had a chance to look at this things yet, and since I'm not a Meyer guy, I figured this would be the place to ask.

    Hope you all are having a great season!

  2. #1 plowtech

    #1 plowtech Senior Member
    Messages: 253

    Even after using it awhile the fluid really doesnt "warm up". It sounds like a "classic case" of water in the system and ice crystals form and block the filter, and the pumps makes a squealing noise because its getting minamal fluid in the pump itself, (in a loose term its cavating). If you HAVE to get going now,use a heat gun to warm the reservoir thouroughly,and operate the unit,if it works great cheange the fluid completely including rams and make sure you use meyer fluid or equivelent. Good luck PT.:waving: