1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Meyer E47 motor runs continuously

Discussion in 'Meyer / Diamond Products Discussion' started by dank1945, Aug 26, 2011.

  1. dank1945

    dank1945 Junior Member
    Messages: 4

    I'm new to this, but very mechanically and electrically handy. I purchased an older Meyer E47 with a TM Series plow, and I'm testing it off the vehicle to sort out any issues before installing it. I connected the battery positive to the starter relay terminal (large), and the large red cable from the top of the E47 motor to the other large relay terminal.
    Without any other connection on the relay (trigger wire is not on yet), when I connect the negative from the battery to the black cable from the base of the E47 motor, the motor runs continuously.
    I have tested the brand new starter relay for continuity, with an ohmmeter, and it check OK, open when not activated, closed when activated.
    Any idea where is the problem?
    Thanks for any feedback!
    Dan
     
  2. dank1945

    dank1945 Junior Member
    Messages: 4

    Hi,
    Sorry, disregard previous post. Somehow I must have screwed up yesterday, because I reconnected everything carefully today, and it's OK. I got raise, and angled to the left. I can't get it to angle to the right though. The saga continues.
    thanks,
    dan