1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Meyer E-60 question

Discussion in 'Truck & Equipment Repair' started by Nice&Green, Dec 3, 2011.

  1. Nice&Green

    Nice&Green Junior Member
    Messages: 19

    So going to pick up my plow for the first time and its about 40mins from my shop where i store it. So im trying to check if everything is working before making the trip. My question is should the main up/down arm work without the plow being hooked up? I can move the arm up and down with my own force. When i press up on the control it makes noise but does not go up. Is this standard? Thanks
     
  2. fordsuvparts

    fordsuvparts Senior Member
    Messages: 135

    Sounds low on fluid.
     
  3. Nice&Green

    Nice&Green Junior Member
    Messages: 19

    Yeah I checked fluid and it was 3"from top and it recommends to be 1-1 1/2"from top so I added. The pump was just rbuilt at the end of last yr and only used once. Maybe something they did is messed up
     
  4. KGRlandscapeing

    KGRlandscapeing 2000 Club Member
    Messages: 2,660

    with the lift arm attached you can pull the ram out and it will go back down cause no pressue is built up but if you were to press up then you shouldnt be able to push it down, enless its in float even then its sort of tough. but to answer your questions its normal when its in the down postion to beable to pull it up and have it go back down
     
  5. Nice&Green

    Nice&Green Junior Member
    Messages: 19

    Awesome Exactly what I was asking Thanks for the help guys only my 2nd year!
     
  6. Nice&Green

    Nice&Green Junior Member
    Messages: 19

    Do you have to have all lines hooked up for pressure to build? Such as the lines from plow?
     
  7. Nice&Green

    Nice&Green Junior Member
    Messages: 19

    should the motor make noise? It just clicks when i press up pad
     
  8. KGRlandscapeing

    KGRlandscapeing 2000 Club Member
    Messages: 2,660

    Did u put the plow on it? the ram will go up in a hurry with no weight on it but yes if u push up the motor should run but u may check all ur connections and check the starter solinoid under the hood check all ur grounds
     
  9. Nice&Green

    Nice&Green Junior Member
    Messages: 19

    No plow on it! Trying to make sure its going to work before making the trip to pick up plow. I will go through my connections.
     
  10. dave_dj1

    dave_dj1 Senior Member
    from NY
    Messages: 350

    When you press up with out the plow the ram should go up, and yes the motor should run.
    It sounds like your motor is not working, check all connections, grounds etc. Maybe take the motor off and clean the interior connections. Those E60's seem to be prone to moisture in the motor. If you find the motor is shot, order a two post replacement motor. It has a separate ground on the motor itself, much more reliable.
    good luck,
    dave :mechanic:
     
  11. Nice&Green

    Nice&Green Junior Member
    Messages: 19

    the clicking is under the hood if that means anything
     
  12. Nice&Green

    Nice&Green Junior Member
    Messages: 19

    All fixed! thx for the help guys! It was the ground post that goes into the motor, the post itself had came loose