1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Marker lights went out???

Discussion in 'Fisher Engineering Discussion' started by ss502gmc, Jan 20, 2011.

  1. ss502gmc

    ss502gmc Senior Member
    Messages: 473

    I just noticed my parking lights went out on plow, not a huge deal but like to have everything working properly. Both directionals still work fine. I checked the fuse by the ISO module and its fine. Ive replaced the fuse before when the parking lights went out before and it fixed it. But not this time. I did the usual bs of checking the plugs and such and all is good. Ive had the plow on for a week and noticed they werent on earlier tonight but were yesterday. Anyone know where else to look? Thanks
     
  2. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,033

    Check your splice for the parking lights by your truck's headlights. There is 3 splices, 2 for your turn signals (one on each side) and one for your park lamps obviously....

    Do you have a 3 or 4 port ISO?
     
  3. ss502gmc

    ss502gmc Senior Member
    Messages: 473

    I have the 4 port iso.
     
  4. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,033

    If you remove your #3 port harness from your ISO, use a test light and check pin H for power (make sure the truck is on and the lights are on) The H pin (brown wire) is the top, middle pin (hold the connector facing you with the latch at the top).
     
  5. ss502gmc

    ss502gmc Senior Member
    Messages: 473

    Thanks for the help! It was the butt connection into the truck side light harness that was the problem. I re spliced the connections and sealed them up and everything works great now!
     
  6. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    I see slobs all them time using non sealing butt connectors and scotch locks when tapping into the wires. Lots of lazy slobs out there.