1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

main solenoid?

Discussion in 'Blizzard Plows Discussion' started by james1115, Dec 9, 2008.

  1. james1115

    james1115 Member
    from CT
    Messages: 81

    I have a blizzard 810 and every year I go to hook up my plow the main solenoid is fried. It is installed right behind my truck front grill, is this the problem? is this common? it keeps freezing up on me every year. thanks for the help.
  2. fastjohnny

    fastjohnny Senior Member
    Messages: 653

    What solenoid are you using? Are you using a continuous duty rated solenoid? Is it the one that looks like a Ford starter solenoid? If so, switch to the Trombetta Bear solenoid.

    Check your wiring, make sure you have good positive and ground cables.
  3. newlooklandscp

    newlooklandscp Senior Member
    from Midwest
    Messages: 473

    Or just use the blizzard OEM one. I have NEVER had to replace one. Have had my first blizzard since 2002.
  4. james1115

    james1115 Member
    from CT
    Messages: 81

    well I used a heavy duty one and built a shield out of sheet metal. It was pouring today and the sheet metal was soaked and the solenoid was dry so we will see how it holds up.
  5. lilweeds

    lilweeds PlowSite.com Addict
    Messages: 1,178

  6. james1115

    james1115 Member
    from CT
    Messages: 81

    nice thanks i am going to order a few for when this one fails:(