1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Low beam

Discussion in 'Western Plows Discussion' started by wideout, Dec 6, 2011.

  1. wideout

    wideout Senior Member
    from iowa
    Messages: 727

    On my wideout drivers side the low beam dont work but the high beam is fine. any ideas?
     
  2. BossPlow2010

    BossPlow2010 PlowSite.com Addict
    Messages: 1,032

    The bulb is out.... :eek:
     
  3. wideout

    wideout Senior Member
    from iowa
    Messages: 727

    That may be true if I had not just put a new bulb in it.
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,960

    Not getting pwr or gnd...see which one u dont have.
     
  5. firefighter1406

    firefighter1406 Senior Member
    Messages: 328

    Had the same problem on my MVP, I found a butt connector in the harness that was full of corrosion that you couldnt see from the outside. Replaced that butt connector and it was good to go.
     
  6. wideout

    wideout Senior Member
    from iowa
    Messages: 727

    I will check for both thank you!
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,960

    The more i think about that,,,your not getting pwr. Bad connection somewhere