1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Low amps

Discussion in 'Boss Plows Discussion' started by RBRONKEMA GHTFD, Jan 21, 2007.

  1. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Hey guys put my plow on today to clean the cement off and I noticed that when I go to angel the plow or pick it up my volts drops. When I am running my plow on my truck it shows about 14 on the gauge. When I go to angel it or pick it up it drops way down and the lights dim considerably. I know that this is suppose to happen a little but not as much as it is on my truck. I checked all my connections and everything is tight. Is there one I missed somewhere? I checked the battery, and the solenoid. My guage reads about 10 ish or so when I am angeling the plow or picking it up. I am going to add that the plow is a 8'2'' poly vee and that the battery is new winter of 05, and the truck is an 02. Also I am reading way past 14 on the guage when the plow is not on, so I know the alt. is in good shape. Help me out guys I am going out tonight to plow so any help would be great.

    Ryan
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Did you check the power and ground connections on the plow itself? I'm assuming this is an RTII or RTIII so remove the cover and check the cable connection's at the pump.Maybe one worked loose.
     
  3. troy28282

    troy28282 Senior Member
    Messages: 178

    Ryan,
    I have that the same problem that you are talking about a couple years ago on my 2001 HD. Changed out the battery first then ran it for a couple events then things went as you were describing and the alternator went out. At that time I only had 3 seasons of plowing on the truck. My suggestion is to get that alternator checked out before things getting worse. GM alternators have problems with the bearing of the spinner.
     
  4. Rangerman

    Rangerman Senior Member
    Messages: 148

    Got another one this time its a blue oval

    I have a 9'2" wee vee mounted on a 1999 F-450 superduty with the V-10 gas motor. We are having the slow plow issues i kind of wonder if it could be in need of an extra battery or second or possibly bigger alt. The truck is starting to show its plowing miles with some serious shifting issues. That is unless 4500-5000 rpms is normal for shifting out of
    1st gear. FORD Fix or repair delay or maybe even twice in an eight hour day. Thanks and hopefully it a cheap fix my boss is a tight one.

    GO COLTS!!!!!!!!!!!!!
     
  5. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Hey guys thanks alot. B&B I am gonna go get the alt. checked tommorrow when I am out plowing. I don't think my contractor would mind.:D . HAHAH. And also thanks for the tip on checking the wires on the pump itself I would have never thought that. The plow is a rtlll mount with a smarthitch (06 model). Thanks again guys and have fun in the snow.payup