1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Loud Schreeeeching noise Western Ultra Mount MVP

Discussion in 'Truck & Equipment Repair' started by Plowboy1, Jan 25, 2011.

  1. Plowboy1

    Plowboy1 Junior Member
    Messages: 7

    Need some help here, When I lift or turn the blade I intermittently get a loud screeching noise that will wake the dead. I have serviced my fluid and filter regularly. When this noise occurs, the blade movement slows drastically. Sometimes it will happen two or three times in a row. Sometimes it won't happen for twenty operations of the blade. Any help is of course greatly appreciated.
     
  2. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,594

    Sounds like ice on the filter, water got into the system. Just happened to mine. My fluid was new in November, but it still froze up. Doesn't take much to cause a problem. Time to flush and fill.
     
  3. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    I have a fisher, so I'm not sure how the motor/pumps compare. I am having the same problem with mine. I was told a couple years ago it was moisture and to flush and fill with a few ounces of seafoam transtune with the fluid. That didn't work for me. I recently read a thread in the fisher forum saying that it is a bushing in the manifold. I bought one, but haven't had time to change it.
     
  4. Plowboy1

    Plowboy1 Junior Member
    Messages: 7

    Thanks for the thoughts, the problem kept happening immediately after draining, flushing fluid and installing new filter.
     
  5. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    sounds like it is low on fluid then.
     
  6. Plowboy1

    Plowboy1 Junior Member
    Messages: 7

    Using genuine Western fluid at the proper fill level.
     
  7. Plowboy1

    Plowboy1 Junior Member
    Messages: 7

    Any Western trained, certified techs out there with an idea on this one?
     
  8. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    i just gave you my idea. call me in the am if you want. i will be in kzoo tomorrow.
     
  9. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Worn bearing sleeve in the manifold. Common problem when you get the screeching.
     
  10. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,594

    Anyone have the Fisher part # ?
     
  11. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    64596 I think it is. It cost me $4 for the kit. I will double check on that before I leave for work, its in the garage.
     
  12. Plowboy1

    Plowboy1 Junior Member
    Messages: 7

    Where is the bearing sleeve located in the manifold assembly? I have an exploded view of the manifold, but I'm unable to locate the sleeve.
     
  13. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

    Where the armature for the pump goes through the manifold to the motor. It can be seen as soon as the motor is taken off. I found the diagram showing it on the fisher web site. I will look for it when I get to work.
     
  14. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    i have a bearing sleeve kit. it comes with an install tool and instructions.
     
  15. 06Sierra

    06Sierra PlowSite.com Addict
    from Maine
    Messages: 1,329

  16. Plowboy1

    Plowboy1 Junior Member
    Messages: 7

    Thank you to No Lead, B&B, and 06Sierra. I'm buying the sleeve repair kit and give it a try. I will post results as soon as I finish and test.
     
  17. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,594

    Is this problem only on the insta-act units?
     
  18. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Generally yes but the Uni's will also do a similar thing when the bushing wears in the motor. They won't usually let out a squeal like a Flostat or Insta-act but they will cause weak operation just like them.
     
  19. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,594

    My SEHP is making a similar noise intermittently, I have a new motor and pump just in case. Still works fine but makes noise?
     
  20. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If it's emulating from the pump unit then it's likely a motor bushing. Good idea on your part to have one on hand. Thumbs Up