1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Lights wont turn on Western Ultramount

Discussion in 'Truck & Equipment Repair' started by lourod996, Oct 19, 2012.

  1. lourod996

    lourod996 Junior Member
    Messages: 2

    I have a fairly new western ultra mount on a GMC sierra. It has the three port isolation module. I wanted to make sure that everything was ready for the season but when I plug in the light harness to the plow the 10 amp fuse on the wire harness going to the isolation module keeps on blowing. There are two fuses only one of them keeps going out. Ive checked all the connections and can't find any bad wires or connections. Can someone please help. I know that if I take it I'm going to be charged an arm and a leg for something that might be simple.

    Thks:yow!:
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    If it's fairly new isn't still under warranty? Why would it cost an arm or leg for something simple? If its simple why isn't it obvious to you? If you checked to make sure none of the normally hot wires were going to dead short (the simple) then it must be complicated.
     
    Last edited: Oct 19, 2012
  3. lourod996

    lourod996 Junior Member
    Messages: 2

    It is not under warranty purchased 4 years ago just has very minimal use. Any help would be appreciated obviously not simple for me since I havent been able to figure it out.
     
  4. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    :waving::waving:
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Did you look at westerns website for the wiring diag?
     
  6. njsnowguy

    njsnowguy Junior Member
    Messages: 13

    I assume you have the upgrade halogen nighthawks?Check for plow bulb housing check if condensation(liquid) slamming the closed circuit due to corrosion