1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Lights Question?

Discussion in 'Western Plows Discussion' started by mezavic, Oct 24, 2008.

  1. mezavic

    mezavic Junior Member
    Messages: 18

    Hi everybody, I'm new to the site and have not posted much.

    I do have a question, wasn't sure if this would be the right section or post it under the "Dodge Trucks" section. Anywho...

    I got an mvp plus installed in my 96 Dodge 2500. I dismounted the plow (ultramount) and left the plow & lights behind and I noticed that when I turn on my headlights in the truck, the high beam indicator was lit all the time. If I flip from low beam to high beam it just gets brighter, but the indicator will stay on. I came down and checked my lights on the front and everything seemed normal. Have you guys had this happen after a new installation? Could it be a loose wire somewhere?

    Any help is highly appreciated!! It annoys me to have the light indicator on when it's in low beams...:eek:

    Thanks,
    Vic
     
  2. Mowman62531

    Mowman62531 Member
    Messages: 96

    There is definently something not right! When you unhook from the plow, the headlights should work like stock. I would re-check all headlight connections for sure.
     
  3. two_superdutys

    two_superdutys Junior Member
    Messages: 5

    You have a ground problem.
     
  4. mezavic

    mezavic Junior Member
    Messages: 18

    Thanks guys...

    Not only I noticed that now, but the temp indicator inside the cabin (for outside temp, not the engine temp light) is way off. It's telling me that the outside temperature is higher, up to 110, when I know it's like 40 degrees outside.

    What could be wrong??:cry: