1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Lights on, switch off, plow doesn't work

Discussion in 'Western Plows Discussion' started by DL313, Dec 9, 2007.

  1. DL313

    DL313 Junior Member
    from MI
    Messages: 5

    91 F-150 parked all summer, used for personal driveway only. Everything worked when parked but now when I plug in the plow the headlights come on without the switch being on, and the joystick will not light-up when power is turned on. Cleaned all connections and tried a new relay on headlights. After I cleaned connections at solenoid I unplugged the 9-pin plug and started to test for power and noticed smoke, hose going to drivers side turning cylinder sprung a leak and fluid was HOT !! Is the motor shorted out and feeding juice to the lights? And literally boiling the fluid in reservoir? Or maybe solenoid stuck in turn position? As far as power to joystick I checked and have power as far as plug in connector located 18" or so down from controller.
  2. beastlyf250

    beastlyf250 Junior Member
    from P.A.
    Messages: 3

    what type/ brand plow is it, did you try changing the controler Solenoid
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You have a ground problem between the plow and battery. Probably due to a poor connection.. the plow is trying to ground through the steel braid in the hoses...

    Go over the ground cable and connections all the way from the pump motor to the battery....
  4. DL313

    DL313 Junior Member
    from MI
    Messages: 5

    Thanks, I had that thought but wondered why only one hose heated up. I checked the other angle supply line and it wasn't even warm, yet alone HOT!! But will definitly check out the ground cable/lead.