1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Lights not working on Unimount Plow

Discussion in 'Western Plows Discussion' started by PGHplowguy, Oct 29, 2012.

  1. PGHplowguy

    PGHplowguy Senior Member
    Messages: 102

    Hello. I have a Western Unimount plow on my 2003 F350 dump. Everything was fine last year and stored safely. I hooked it up and at first none of the lights on the plow worked. After a little while the blinkers started working. The head lights still do not. It does not matter if the truck lights are just on or if the truck is running.

    Any ideas will be appreciated. Thank you.
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    Ok. Ck all your gnds. Don't just look at them,,,take them off and clean. Ck and clean the gnd at the grill connectors and at the plow...dont use a meter. Use test light only do that then report back
     
  3. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    On those plows the lights ground out through the main motor ground cable. You will see a smaller Blk with org tracer going from the light harness on the plow to the negative motor lug, Check that wire for damage as far up as you can and make sure it is not loose on the motor lug.

    Of course this only applies if you have a flowstat uni. If you have the Isarmatic (older with intigrated lift cylinder) there may not be such a ground. Do as Dieseless suggests, clean your grounds and your grill plugs then lubricate the plugs with dilectric grease. If it still doesn't work let us know exactly what kind of plow it is. Straight blade or V, two or three plugs at the grill, Isarmatic or flowstat hydraulic unit. Then we can link you to the correct schematic and give you tips on what would cause this kind of problem.
     
    Last edited: Oct 29, 2012
  4. PGHplowguy

    PGHplowguy Senior Member
    Messages: 102

    Thanks guys for the tips. After the never ending rain and flooding stops I'll get outside and mess with it. I'll post as soon as it is fixed or still in need of help.
     
  5. PGHplowguy

    PGHplowguy Senior Member
    Messages: 102

    Problem solved. It was the relays. So simple, but a pain to find. Thanks for the help guys.:mechanic:
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,973

    There are aftermarket relays and relay connectors if your interested