1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Lighting problems

Discussion in 'Fisher Engineering Discussion' started by Plow37, Jan 9, 2007.

  1. Plow37

    Plow37 Junior Member
    Messages: 9

    Hi all newbie question, I have a 1999 F450 with a 9' fisher plow, on low beams right side lights work on high beams left side lights work I cannot get both lights to work at same time, how can I fix this, already replaced both bulbs.
     
  2. chaseatg

    chaseatg Member
    Messages: 94

    how many plugs

    Do you have a two or three plug system?
     
  3. Plow37

    Plow37 Junior Member
    Messages: 9

    It is a three plug system.
     
  4. chaseatg

    chaseatg Member
    Messages: 94

    Did you just put this plow on?
    If so check the config plug.
    Should be configered a to b also make sure the wireing plugs at the headlights and the isolation module are configered the same way.
     
    Last edited: Jan 10, 2007
  5. Plow37

    Plow37 Junior Member
    Messages: 9

    I bought the plow with the truck thought that it was just a bad bulb so did not pay to much attention before. Can you explain what you mean by configuration plug.
     
  6. chaseatg

    chaseatg Member
    Messages: 94

  7. Plow37

    Plow37 Junior Member
    Messages: 9

    Yes the lights work fine with the plow off of the truck
     
  8. chaseatg

    chaseatg Member
    Messages: 94

    Then the first thing I would check is the condition of the 11 pin plug at the grille, make sure all the pins are in good order and that they are clean of any corrosion. Clean the connections with a all purpose oil such as WD-40, and lube with dielectric anti corosion compound.
    Most of the time light problems are because of a bad electric connection.
    Check and clean the ground wird from the lights to the plow motor and also check and clean you battery cables on the truck, make sure both the positive and negitive cables for the plow are connected directly to the battery.