1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Light Problems..please help.

Discussion in 'Fisher Engineering Discussion' started by Stark_Enterprises, Dec 19, 2006.

  1. Stark_Enterprises

    Stark_Enterprises Senior Member
    Messages: 318

    Hers's the Situation.: I have a 98 Ram 3500 Cummins. Bought the truck about a year ago. It had a 8ft MM1 with the 2 plug setup. I wanted a biger plow so i bought a used 9' MM2 with a 3 plug setup. I also bought a used iso. mod. I disconnected everything that had to do with the 2 plug setup and proceeded to hook up the 3 plug setup. I had to change a couple of the pins at the iso mod and at the harnest for the headlights. This morning was the first chance i got to hook up the plow. Well i hook-up and proceed to raise the plow up and angle left and right and then Drop it down again - Everything worked perfect. I was pretty happy. UNTILL I turn on the lights. The main headlights work perfect both low and high beams. Heres where the problem comes in- Passenger side park light (aka - the orange part of the light ) is out completly. Driver side park light is lit normally. So i proceed to try the passenger side blinker- Its working normally - Blinking brite. I then shut blinker off and still the park light is out. Then proced to try the Driver side blinker- I go look and what do i see. The driver side light blinking very dim, but ALSO notice the freaking passenger side is also blinking but blinking brightly. Just to note It makes no difference if the headlights are on or off. Also With the 4 ways on the same thing happens--Passenger side is blinking bright and driver side is blinking VERY dimly...Also All blubs are good..
    To the Fisher Vets on here.....
    Could this be a ground issue?, Do you think the problem is with the plow wiring or the truck wiring? What ever the problem is it just annoys the *h*t out of me!
    Thank -you ahead of time for your :help:
  2. BigDave12768

    BigDave12768 PlowSite.com Addict
    Messages: 1,446

    You crossed a wire. Or more than likely the used plow you bought has a bad cable on it. You can buy a replacement. But you have a broken wire in their. Have a buddy stand in front of truck while you bend and move the wires. Se what the lights do. More than likely you will just need a replacement cable. One other thing while installing this plow did you soldier the connections or did you use butt conectors?
    Last edited: Dec 19, 2006
  3. daninline

    daninline Senior Member
    Messages: 430

    You might also want to check the bulp someone might of put in the wrong one in.
    I have seen this before and it will make all the light blink at the same time.

    But I would bet it's a crossed wire also.

    PS do you still have the old setup, if you want to sell it xysport

    Good luck.