1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

light bar rubs and pin alignment

Discussion in 'Blizzard Plows Discussion' started by lokasj, Jan 19, 2008.

  1. lokasj

    lokasj Junior Member
    Messages: 1

    I have a new 760 hd. The bottom of the light tower rubs on the plow pivot. Has anyone else seen this problem. The dealer where i bought it said he could just grind a little off the bottom of the light bar but if this is manufactured incorrectly i wonder what else on the undercarriage is wrong. For instance when i use the quick hitch to pull the plow in it aligns the driver side bushing and pin perfect but the passenger side is 1/4 inch off. As for the alignment problem the dealer said this is all in my head. What's your take??

    Thanks
    steve
     
  2. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    What he said.:rolleyes:
     
  3. magnatrac

    magnatrac PlowSite.com Addict
    Messages: 1,055

    I had to take a grinder to my light bar mount last year when I raised it as high as it could go. It was hiting my bumper. I guess it is just how it is. If your pins don't line up I don't know what to say. I never even use my draw latch, just the power hitch . It works everytime. Anyways I hope it all works out. Good Luck !!!
     
  4. purpleranger519

    purpleranger519 Senior Member
    from Kansas
    Messages: 536

    In your head.....sorry.
     
  5. blizzard G

    blizzard G Junior Member
    from detroit
    Messages: 4

    Rest assured it's not in your head. Blizzard has made a few changes over the past ten years to there mounts and light bar attachment. I just put a new 860 SW on my 2003 GMC 2500HD and have the same issues. When I use the Power Hitch to pull the plow all the way into the truck side mount it pulls it in on one side but not the other, I have my plow on a gravel driveway so that may have something to do with it. As for the light bar getting hit mine does that to. A small fix with a hand file and a dab of paint. Just make sure that you file the light bar and not the A frame guide plates.
     
  6. plowboy21

    plowboy21 Member
    Messages: 30

    yeah i tried it on my 860sw and the hook up theres somethin with gravel it dose not like now on concret or pavement it fine