1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Lifting/Lowering problems with ultra mount

Discussion in 'Western Plows Discussion' started by helihansen, Dec 30, 2012.

  1. helihansen

    helihansen Junior Member
    Messages: 2

    I have an Ultra Mount plow with isolation module in an F250 that I bought last year and have been using since then without issue. I have changed the fluid and cleaned the filter each year. I only use the plow for my driveway and a few neighbors. Last night I was plowing and when I went to lower the plow nothing. Left and Right angles still worked as they should. I returned home and did some reading in the mechanics guides posted online and removed my S1 coil. As soon as I removed the S1 coil fluid came out and the plow lowered. I bench tested the S1 coil and it seems to be working correctly. After re-installing S1 the plow will now not raise and when prompted by the controller it angles left. I checked all S1,S2 and S3 coils and I have power to each one when prompted by the controller. Any ideas? Thanks
     
  2. helihansen

    helihansen Junior Member
    Messages: 2

    Just wanted to give an update that the plow is now fixed. It ended up being the S2 cartridge. Seems that the S2 cartridge is also energized when lifting and when I took it out it was stuck closed. After cleaning with parts cleaner and re-installing all is well. Thanks