1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

lesco problems

Discussion in 'Ice Management' started by rfed32, Oct 4, 2007.

  1. rfed32

    rfed32 Senior Member
    Messages: 473

    i have a lesco mini spreader and i went to hook everything up tonight and when all is pluged in the spreader doesnt spin and the control box like will stay solid then blink 3times and it will just do it
     
  2. CNYScapes

    CNYScapes Senior Member
    Messages: 136

    try spinning it by hand first. its locked up. that worked on mine when it did that after a few years it wouldnt move at all. The parts to fix were too much so I sold it on ebay for like $200 and bought a new one.
     
  3. rfed32

    rfed32 Senior Member
    Messages: 473

    i only paid 100 bucks for it last year and it worked fine...its 2yrs old...my uncle had it b4 me and got out of the plowin biz couldnt sell so i bought it for that much...no warrenty left on it...im gonna go out and spin it now and ill see what will happen ill keep ya posted
     
  4. powerjoke

    powerjoke PlowSite.com Addict
    Messages: 1,341

    Beat on it LOL

    put jumper cables directly on the motor terminals (no controller) and tap on the motor with a wrench, not too hard becouse there is magnets glued to the motor case
     
  5. powerjoke

    powerjoke PlowSite.com Addict
    Messages: 1,341

    Beat on it LOL

    put jumper cables directly on the motor terminals (no controller) and tap on the motor with a wrench, not too hard becouse there is magnets glued to the motor case
     
  6. ptllandscapeIL

    ptllandscapeIL Senior Member
    Messages: 495

    powerjoke is right you have to silicone lube EVERY moving part EVERTIME it snows to prevent this