1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Leo Wiring? Help

Discussion in 'Truck & Equipment Repair' started by Plowguy7, Feb 13, 2011.

  1. Plowguy7

    Plowguy7 Junior Member
    Messages: 2

    So I bought a 9' Leo from a private seller and decided to install myself. Install went fine until it came to the wiring...After pulling the controller apart to see what wire went to what switch and hooking everything up I got a whole lotta clicking but no movement. I decided the solenoid must be bad so I went a bought another. I hooked everything up and it worked great for all of 5 seconds until my ground wire smoked and melted. Replaced that and now nothing but clicking and smoking...what am I doing wrong or what is hooked up wrong? Please help spent my budget on the plow and have no money to take it in. Thanks!
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    a picture would go a long way.

    NICHOLS LANDSCA PlowSite Veteran
    Messages: 4,286

    Just run to Truck Utilities they have a generic wire diagram already printed off. Why did you have to pull the controller apart? The plug only plugs in one way?

    Were you trying to figure out the correct wiring on the pump? Red wire to right angle ( hyd, tank side) Black wire is down (middle valve) Orange wire left angle (motor side) White wire to the solenoid (small terminal) either one it doesn't matter Green wire is 12V power (ignition on) Blue is ground. If you have a separate red wire coming out of the controller but don't have a red wire on the harness to hook it to leave it unhooked. How's that?
    Last edited: Feb 13, 2011