1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Lean Mixture Adjustment?

Discussion in 'Chevy Trucks' started by JB, Apr 26, 2000.

  1. JB

    JB Member
    Messages: 46

    I still think my 88 K-5 Blazer is running lean. There is a rich gas smell at times and upon the first start of the day there is a slight puff of black smoke from the tailpipe (Rich). After I reattached the EGR wire and resolved the Check engine light the smell lessened up. I then discovered that the air intake was not opening at the heat riser and was starving for air (rich) so I corrected that. The smell cleared up quite a bit more but there still is a slight smell of unburned fuel that should not be there. There are no codes stored in the computer at this time and the oxygen sensor is new. Any suggestions ? Thanks in advance. JB
     
  2. yortengel

    yortengel Senior Member
    Messages: 123

    It sounds like its time to have a complete scope test run. You need to find a shop with a four or five gas engine analizer, and an ignition scope. Like a SUN 450. With this type of tool they will be able to determine if your engine is running correctly. I used to run these tests all the time. very accurate. I found lots of hard to find problems with it. the only catch is we got $120.00 for the test. But if it fixes the problem. I never had any complaints.
     
  3. JB

    JB Member
    Messages: 46

    Thanks for the info. I will get in touch with the Chevy dealer here and see if they have the analizer you mentioned. I checked some of the sensors but there seems to be no culpret. I was told the TBI base gasket could be leaking and cause it to run rich. What do you think? Thanks again, JB
     
  4. yortengel

    yortengel Senior Member
    Messages: 123

    If the TBI base gasket was leaking, it would cause the truck to run Lean. and the Idle to be High. They are very common. Usally the customer had a High Idle complant. If its staying a little rich. this would be caused be something like the purge solenoid stuck. or the fuel pressure to high. or maybe a leaking injector. also a bad Coolant temp sensor will cause this type of problem. Its also very important to make sure that the thermostat is operating at the right temperature. Anyway these are some of the more common problems.<br>Good Luck. Keep us informed.<br>Yort.
     
  5. JB

    JB Member
    Messages: 46

    Yort;<br>I went to the Chevy dealer and was told they had all the equipment to scope the engine, for $85.00. I planned to bring it in tommorow. I figured I would check one more thing before though; the timing. The underhood sticker says it should be set at 0 BTDC. It turned out to be set at 14 BTDC by the previous owner. I adjusted it to specs and test drove it. Much more power and NO UNBURNED FUEL SMELL. I dont know why I did not think to check the timing first. JB