1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Just installed new Fisher XV2 on Ram 2500 and NOTHING works

Discussion in 'Truck & Equipment Repair' started by justbarriault, Dec 10, 2015.

  1. justbarriault

    justbarriault Junior Member
    Messages: 15

    Hi all, I just installed a new XV2 on my new Ram 2500 with 6.4 gas engine and I have nothing. No headlights, no power to Fishstik, etc. The harnesses they gave me came with a couple adaptor harnesses, one with 2 relays, one with 3 and not sure if i needed both? Any help is appreciated, thanks
     
  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,669

    My understanding the relay adapters are to deal with trucks that have both low and high beams on at the same time.

    The two 4 pin connectors under the hood on the control harness. The one at the very end goes to the battery harness. the other one in the middle goes to the light harness. If these are backwards it will not work. Make sure your switched ignition source is 12v. Some circuits on these newer trucks run 5v for computer, this not enough to power the plow system.
     
  3. justbarriault

    justbarriault Junior Member
    Messages: 15

    On the relays, I read that for the two relay harness but not sure about the three. GOOS point on the 5 volt digital signal for multiplexing too, I will check. I just used a test light. I tried putting the adaptor harness in the other location with the same plug just to double check and it didn't change anything

     
  4. Rangers recover

    Rangers recover Junior Member
    Messages: 25

    Did you get it fixed ????
     
  5. justbarriault

    justbarriault Junior Member
    Messages: 15

    Not yet, will look again tonight

     
  6. Rangers recover

    Rangers recover Junior Member
    Messages: 25

    Let me know got a buddy master with fisher
     
  7. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,244

    What year is the ram?
     
  8. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,669

    Not what I meant, those two 4 pin plugs can be switched. If they hooked up backwards the plow will not work. Nothing to do with the adapters.
     
  9. justbarriault

    justbarriault Junior Member
    Messages: 15

    Ram is a 2015. I didn't see how the 4 pin plugs could be swapped. I will have to investigate since if that's the case I very well could have screwed those up
     
  10. justbarriault

    justbarriault Junior Member
    Messages: 15

    It's really too bad they couldn't give a full diagram with everything on it, not three different diagrams, each excluding various harnesses
     
  11. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,244

    oh those are a fun install

    at least one of the relays are for the turn signals,
     
  12. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,669

    Which side of the truck did you connect the battery harness to?
     
  13. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,669

    These are the plugs I am talking about.

    Screenshot (3).jpg
     
  14. justbarriault

    justbarriault Junior Member
    Messages: 15

    I will look when I get home tonight. I know I did not connect the battery harness to the 3 relay harness, I connected that what what I believe was illustrated in the main manual, with neither of the harnesses containing relays. I do believe I connected the accessory wire to a 12V source as I used a 24V test light and it was still pretty bright. I think 5V would have been very dim. The wire I connected to was fairly large as well, probably a 10 or 12 gauge(ish) under the dash
     
  15. justbarriault

    justbarriault Junior Member
    Messages: 15

    I believe it's connected to the lower 4 pin connector
     
  16. justbarriault

    justbarriault Junior Member
    Messages: 15

    And another FYI, I did not connect "Park" or turn signal wires. I don't have daytime running lights and I usually don't connect the turn signal wires due to the risk of corrosion
     
  17. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,669

    They need to be connected. Won't keep plow from working but may keep lights from working.
     
  18. justbarriault

    justbarriault Junior Member
    Messages: 15

    Kimber, which connection should the adaptor harness plug into on your screen shot?
     
  19. justbarriault

    justbarriault Junior Member
    Messages: 15

    Yup, has the 4 pin connectors wrong. About the only thing on this so far that I could possibly screw up. Thanks!

     
  20. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,669

    Adapters go to the 4 pin in the headlight harness.

    I did the same thing on my first fleet flex install, why Fisher didn't make the two plugs different we will never know.