1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

JS Barnes Pump 1260101

Discussion in 'Truck & Equipment Repair' started by rgrandma, Sep 3, 2009.

  1. rgrandma

    rgrandma Junior Member
    Messages: 2

    Good evening. New to the forum. I have a 89 Ford F250 with a Diamond Plow on the front of it. It has a electric hydraulic Pump. The pump is a JS Barnes Pump. Now it has power to it, when I move the left, right, up and down the pump runs, but the plow doesn't move. The lady I bought off of says that the think they ran the pump without oil. It was low. I added the oil needed and it still doesn' t move the plow. Does anyone have any information or know of a site that could lead me through a troubleshooting routine? Thank you in advance for any help..

    Rene G.
     
  2. noble@esitrucks

    noble@esitrucks Member
    from 20181
    Messages: 92

    do you have a picture of the pump? that you can share with us.
     
  3. rgrandma

    rgrandma Junior Member
    Messages: 2

  4. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    So what you have there is a pump with a seperate valve body which was pretty common back in the 80's.

    You need to verify that the pump is putting out any pressure so your going to have to get a hydraulic pressure gauge (min of 3000 psi) . You can either T into the pressure line or go staright into the pressure gauge from the pressure line. Since theres 2 lines coming from the pump you may have to try both lines to find the one that builds pressure. Start with that and lets us know what you get for psi.