1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice


Discussion in 'Jeeps' started by BigDBoots, Oct 30, 2011.

  1. BigDBoots

    BigDBoots Senior Member
    Messages: 102

    So, while plowing in the freak storm we had up here my 4wd gave me an issue. I can put the vehicle into 4wd but the indicator light on the dash does not illuminate. Any ideas of what may cause this? There are no others issues.... that I am aware of. 4.0 engine, manuel trans, 48,000 miles
  2. festerw

    festerw Senior Member
    Messages: 986

    It's either a burned out bulb or the switch is misaligned or broke. There is no disconnect I'm aware of so if the lever is 4WD it's in 4WD regardless of the light being on.
  3. BigDBoots

    BigDBoots Senior Member
    Messages: 102

    thanks fester, I doubt the bulb is burnt out since the rest of the dash is all good, but could be. I made some calls and was told about the switch so I am waiting for things to warm up a bit here in NJ after this freak storm and will figure it out under there, thanks again
  4. Hubjeep

    Hubjeep Senior Member
    Messages: 501

    Yeah, there may be a switch on the T-case.
  5. theplowmeister

    theplowmeister 2000 Club Member
    from MA
    Messages: 2,515

    There IS a switch on the transfer case
  6. Jeepm@n

    Jeepm@n Member
    Messages: 48

  7. bschurr

    bschurr Member
    Messages: 60

    From time to time my 4x4 light doesnt illuminate but my 97 TJ is definately in 4WD. The switch could be bad or perhaps just a loose connection...