1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

JD250 Skidsteer. Loss of aux power

Discussion in 'Heavy Equipment' started by Scottscape, Jan 7, 2011.

  1. Scottscape

    Scottscape Senior Member
    Messages: 662

    I have no power to lights, heater and wiper. check fuses. been looking for bad ground and cant find one. sometimes it will they will pop on when its running if the switches are turned on. I can't find a loose connection anywhere. Any ideas?
     
  2. NICHOLS LANDSCA

    NICHOLS LANDSCA PlowSite Veteran
    Messages: 4,312

    Ignition switch, fuse block? Just trying to brain storm the not so obvious. edit Have you been able to check for power at the fuses for everything that isn't working, when it isn't working?
     
    Last edited: Jan 7, 2011
  3. Scottscape

    Scottscape Senior Member
    Messages: 662

    I must add that everything else works..
     
  4. Snowzilla

    Snowzilla Senior Member
    from Iowa
    Messages: 397

    Sounds like complete circuits & intermittent. Like Nichols mentioned, maybe it is the connections to or from the fuse block. Not sure what a Deere is like. But maybe a nut vibrated loose on stud. Pull any shields off so you can better inspect the integrity of the fuse block.

    sidenote: I rented a JD250 once and the battery discharged. The nut was loose on the 12v+ wire on the alternator.