1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Isolation module troubles on superduty

Discussion in 'Blizzard Plows Discussion' started by GLS, Dec 27, 2008.

  1. GLS

    GLS Senior Member
    Messages: 248

    We are getting our new ford superduty setup with a blizzard hitch and wiring.

    We got the mount on just fine, but we are having a problem with the wiring.

    We can't get the headlights to switch to the truckside when the light tower is hooked up. If we unhook the plow headlights, then they switch back over to the truck.

    Everything else works fine, just the headlight switch.

    Any ideas?

    Thanks
     
  2. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    I will have to dig it up, but there is a service bull. on 08 and up Superduty's where you have to clip a wire in the headlights. I just can't remember which one off the top of my head. I believe you unplug the diode ground jumper wire in the headlamp housing and tape it off, and then the lights will work normal. It's basically got too many grounds.
     
  3. GLS

    GLS Senior Member
    Messages: 248

    Any more info on this?

    You'd think they could have included this with the instructions!!

    Thanks
     
  4. newlooklandscp

    newlooklandscp Senior Member
    from Midwest
    Messages: 476

    you need another wiring harness for the headlights to override the new 08 computer system.
     
  5. lilweeds

    lilweeds PlowSite.com Addict
    Messages: 1,178

    I have heard the reason for the module has to do with the Turn Sigs. Someone once told me if you run LED bulbs in the blizzard lights you won't need the ISO.
     
  6. GLS

    GLS Senior Member
    Messages: 248

    Got it working. We ended up opening the plow headlights and disconnecting a white wire from a white/red wire. All works well now!
     
  7. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    glad to see you got it going by disconnecting the diode ground harness like i said. JOHN