1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Isarmatic Mark 3 motor runs constantly

Discussion in 'Western Plows Discussion' started by RichieTNy, Jan 28, 2009.

  1. RichieTNy

    RichieTNy Junior Member
    Messages: 5

    Hey Guys,

    I have a Western plow pump mentioned above. The motor to the pump runs all the time even when the key is off. The plow works fine, but this problem wears down my battery till my jeep battery is dead. Do you think its the solenoid?

    Thanks in advance. :D
  2. Dissociative

    Dissociative 2000 Club Member
    Messages: 2,066

  3. CityGuy

    CityGuy PlowSite Fanatic
    Messages: 16,906

    something doesen't seem to be wired right or solinoid is bad
  4. Moonlighter

    Moonlighter Senior Member
    Messages: 643

    Motor relay could be sticking or always energized - Short circuit in vehicle harness - and or malfunctioning controller. From mechanics guide troubleshooting section. Hope this helps.

    Moonlight Snow Removal
  5. RichieTNy

    RichieTNy Junior Member
    Messages: 5

    i changed the solenoid and still have the problem.
  6. sechracer

    sechracer Senior Member
    Messages: 478

    then you have a short that is grounding the solonoid at all times....